Back to overview
Downtime
Some services are down
Jun 02 at 10:20pm BST
Resolved
Aug 03 at 11:49pm BST
This issue has been resolved
Affected services
Updated
Jun 02 at 10:40pm BST
The affected server has been restarted and we are seeing some improvements, there is expected to be degraded performance on the website and it may run slower than usual.
Affected services
Created
Jun 02 at 10:20pm BST
We have identified an issue which means our Web Design Digital Domains website is currently offline. Our team can still make amendments, help with billing queue re and process new orders via email or phone.
Affected services